Drumagog 5 + Cubase 5 = Issues!

Moderators: Rim, Corey W

Post Reply
twentydollarjim
New Member
Posts: 1
Joined: Tue Mar 26, 2013 7:36 am

Drumagog 5 + Cubase 5 = Issues!

Post by twentydollarjim » Tue Mar 26, 2013 7:38 am

Hi guys,

I decided to grab a copy of Drumagog 5 after seeing it in action in a recording studio in the UK - the finished result of which sounds immense.

I use Cubase 5 and Addictive Drums and have activated all outputs so that I have access to AD's individual mono channels. Basically I'm applying Drumagog replacements to the kick track and the snare track. The kick replacements seem to work more or less 100%. With the Addictive Drums overhead/room mics activated, the whole thing sounds pleasant and is in sync.

The snare track is another issue altogether. It'll perform perfectly throughout a section (flams/fills present) and then terribly in another section that by comparison is simpler. The main problem seems to be that in these affected sections Drumagog seems to loose sync with the Addictive Drums overhead/room mics, which is very strange considering the fact that it is ok in other sections, in both slow and moderate tempos. There are other oddities also like flams that aren't recognized at all, despite them being clearly defined when listened to without Drumagog activated. I've tweaked most of the available settings to no avail.

Absolutely dumbfounded. Not sure where to go from here to sort this out! I really want to get this sorted as the sound I have achieved thus far is the best drum sound I've ever worked with.

Thanks for your help guys!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests